Building a 2.11BSD tape for Supnik's emulator

Markus Leypold leypold at
Sat May 27 00:40:23 AEST 2000

Hello Seth,

I never worked with a real PDP-11. I tried to build a V7 Boot tape for 
the Supnick and still did not succeed, but I got the following impressions:

 * V7 Doc says, You can't use the bootstrap from the DEC bulk ROM,
   but need to key in a custom bootstrap. Have a look into
   the V7 Manual Volume 2B (Essay about Installing UNIX).

 * It seems, a tape also needs to contain labels for the files
   (512 Byte Records), kind of directory.

Regards -- Markus

Original Message:
Hello folks,

I'm trying to build a 2.11BSD boot tape for Bob Supnik's emulator.  I
downloaded the tape files from Distributions/ucb/2.11BSD, and put them
together with the following commands (on Linux):

  cat mtboot mtboot boot | dd of=file0 obs=512
  dd if=disklabel of=file1 obs=1024
  dd if=mkfs of=file2 obs=1024
  dd if=restor of=file3 obs=1024
  dd if=icheck of=file4 obs=1024
  dd if=root.dump of=file5 obs=10240
  dd if=file6.tar of=file6 obs=10240
  dd if=file7.tar of=file7 obs=10240
  dd if=file8.tar of=file8 obs=10240
  cat file? > boot.tape  [I've verified the shell expands this
                          expression to the correct file order]

But when I run the simulator and try to boot from the tape (with or
without the -o optiont to 'boot'), it fails, like so:

  % pdp11

  PDP-11 simulator V2.3d
  sim> set cpu 18b
  sim> set cpu 2048K
  sim> att tm0 boot.tape
  sim> boot tm0

  HALT instruction, PC: 000002 (HALT)
  sim> boot -o tm0

  HALT instruction, PC: 000002 (HALT)

It's like the bootstrap code isn't working.  Or possibly I've completely
misunderstood the proper way to build a tape image.  Is there a better
way to go about it?

- -Seth

Received: (from major at localhost)
	by (8.9.3/8.9.3) id CAA45296
	for pups-liszt; Sat, 27 May 2000 02:31:58 +1000 (EST)
	(envelope-from owner-pups at

More information about the TUHS mailing list