[pups] Swap device in V6?

Ian King iking at microsoft.com
Wed Feb 28 02:56:06 AEST 2001

The good news is, this fixed my ps problem - ps now works.  The bad news
is that cc still fails with the following error:

fFatal error in /lib/c0

The lowercase f appears, followed shortly by the rest of the line.  I've
tried the -c option to suppress linking, and still get this error.  I
don't get this error on the Supnik emulator.  

Obviously, one way to do things would be to rebuild the kernel on the
emulator, and transfer it to the PDP-11.  But that seems like cheating.
:-)  Besides, the Supnik emulator is just too freeform; my 11/34a
doesn't have a half-dozen instructions the emulator implements.  I've
tried the DBit E11 emulator (since it gives more control over processor
features), but I can't get it to boot these images. -- Ian 

-----Original Message-----
From: Jay Jaeger [mailto:cube1 at home.com]
Sent: Monday, February 26, 2001 7:51 PM
To: pups-digest at minnie.cs.adfa.edu.au
Cc: kwellsch at tampabay.rr.com; johnh at psych.usyd.edu.au
Subject: Re: [pups] Swap device in V6?

In case someone didn't put 2+2 together...  The V6 distribution has
unix kernels.  I don't recall for sure which kernel is linked to /unix,
for sure it is only one of them.

So, if /rpunix is linked to /unix, and you boot rkunix, and then do a
it will search /unix for the symbol for swapdev, look for the RP device
/dev, and not find one.  no swap dev.

The cure is, of course, quite simple:

# chdir /
# ln rkunix unix

And ps will now work fine.

[ Ian might have gotten this directly had he not hidden his real e-mail 
address...  ;-) ]

Jay Jaeger

At 09:32 AM 2/27/01 +1100, you wrote:

>Date: Sun, 25 Feb 2001 23:49:22 -0800
>From: "Ian King" <iking at killthewabbit.org>
>Subject: [pups] Swap device in V6?
>This is a multi-part message in MIME format.
>- ------=_NextPart_000_0007_01C09F85.94050E80
>Content-Type: text/plain;
>         charset="iso-8859-1"
>Content-Transfer-Encoding: quoted-printable
>I'm working with the install image provided by Ken Wellsch, and when I
>execute the 'ps' command I get an error that says "no swap device".
I'm =
>Date: Mon, 26 Feb 2001 10:27:12 -0800
>From: Ian King <iking at microsoft.com>
>Subject: RE: [pups] Swap device in V6?
>I, too, have /dev/rk0 mknod'ed as 0,0.  Relaetd to this, ps does
>odd (at least to my experience) with the open() system call - it calls
>("/dev")', without a second argument for mode; that seems like a no-no
in C,
>- -----Original Message-----
>From: Ken Wellsch [mailto:kwellsch at tampabay.rr.com]
>Sent: Monday, February 26, 2001 9:52 AM
>To: Roger Ivie
>Cc: PUPS at minnie.cs.adfa.edu.au
>Subject: Re: [pups] Swap device in V6?
>The "ps" command source appears to be poking around /dev looking for a
>block device that matches the kernel value for swapdev (or something
>that) and confirming it is a block device.
>Yet I see I have /dev/rk0 mknod'ed 0/0 and it is a block device but
>still gripes about "no swap device."
>So I'm missing something I guess.
>Date: Tue, 27 Feb 2001 08:44:23 +1100 (EST)
>From: John Holden <johnh at psych.usyd.edu.au>
>Subject: Re: [pups] Swap device in V6?
<< snip >>

>The 'ps' command looks up the symbol table of the unix kernel, and gets
>the device entry for swap (_swapdev), and the process table (_proc)
>It would open /dev as file, and read the directory entries to find a
>device entry, so it then had the name of a device to open (you cannot
>a device based only in the major and minor device entries from a user 
>It also uses /dev to decode tty entries into names.
>For 'ps' to work correctly, /unix had to be linked to the real kernel,

Jay R. Jaeger					The Computer Collection
cube1 at home.com			visit

Received: (from major at localhost)
	by minnie.cs.adfa.edu.au (8.9.3/8.9.3) id FAA61575
	for pups-liszt; Wed, 28 Feb 2001 05:32:00 +1100 (EST)
	(envelope-from owner-pups at minnie.cs.adfa.edu.au)

More information about the TUHS mailing list