[TUHS] simh vax and 4.3-quasijarus

Gunther Schadow gunther at aurora.regenstrief.org
Thu May 23 07:07:28 AEST 2002


I found SIMH really handy as opposed to a real VAX. Was the only
way I could bring my VAX 6460 to boot Ultrix 4.5 which I only had
on a CD and the standalone kernel that came with Ultrix 4.5 didn't
support the KA64A although the normal generic Ultrix 4.5 kernel
does. So, I made a small disk installed a generic root partition
on SIMH used an uVAX-II under NetBSD to pull the disk image via
NFS to a TK50 and then booted VAX 6460 under VMS and wrote the
disk image to RA90 and off I went. I couldn't have done it without
SIMH :-)

Anyway, to your problem:

>>here's what I see, complete transcript at the end
>>>>>>boot dua0
>>>(BOOT/R5:0 DUA0)
>>>  2..
>>>HALT instruction, PC: 00000C1A (MOVL (R11),SP)

this suspiciously looks as if the HALT is from SIMH not from the
VAX it simulates. There are two halt levels in SIMH, one being
the VAX halting and going into VAX console mode, the other being
SIMH halting. Are you absolutely sure that you have a proper
VAX console with SIMH? You should get normal VAX console
behavior, try a few commands and see whether you're on the right

Also, be sure you have it all configured right, that you have
the right devices defined and properly associated with files
on the hosting OS etc.

>>that's obviously not what I want. I tried all combinations of
>>installboot and disklabel -B I can think of, both in netbsd and
>>quasijarus, and all lead to the same result.
>>Can anybody tell me the exact incantations necessary to install
>>the bootblocks for quasijarus0a [...]
> This seems like a simh problem, or, more probably since you can boot That Other
> OS successfully, a problem with your installation of 4.3BSD-Quasijarus0a masked
> by a simh problem. 

I would agree. What other system can you boot on SIMH?

>>Ultrix 4.3 gives me:
>>>466788+254256+177476+[36984+34990] total=0xecfa2
> OK, so the kernel has been loaded successfully.
>>>machine check 82: vap 82000004 istate1 7c000c00 istate2 c070fe pc 80001c61 psl 41f0008
>>>r0=8000000c, r1=8000167c, r2=0, r3=211bd0dd, r4=0, r5=dd274
>>>panic: mchk

 > Since Ultrix V4.3 perfectly supports the KA655 CPU, this again must be a case
 > of simh misemulating it.

again, your SIMH configuration may be screwed up. I definitely could
boot Ultrix 4.5.


Gunther Schadow, M.D., Ph.D.                    gschadow at regenstrief.org
Medical Information Scientist      Regenstrief Institute for Health Care
Adjunct Assistant Professor        Indiana University School of Medicine
tel:1(317)630-7960                         http://aurora.regenstrief.org

More information about the TUHS mailing list