[pups] 2.11 on an 11/44

Bill Gunshannon bill at cs.scranton.edu
Fri Feb 28 02:42:29 AEST 2003

On Thu, 27 Feb 2003, Johnny Billquist wrote:

> On Thu, 27 Feb 2003, Bill Gunshannon wrote:
> [...]
> > Now the problem.
> > The system boots fine.  And it will mount /dev/rl1a.  But it won't mount
> > /dev/rl2a.  I get "/dev/rl2a on /vol2: No such device or address".
> > I get the same error when I try to do a disklabel.  What's more, I also
> > get this same error when I try to access any of the RA devices.  I am
> > using the GENERIC Kernel which I assume has all the devices in it.
> >
> > Anybody have any suggestions??
> What do you see at boot time? Does it show all three RL02s and the
> mscp-controller along with disks?

Actually, I am surprised by the lack of information provided.  I guess
the newer BSD's have spoiled me.  :-)

>>>boot dl0

44Boot from rl(0,0,0) at 0174400
: rl(0,0,0)unix
Boot: bootdev=03400 bootcsr=0174400
2.11 BSD UNIX #5: Thu Jan 11 21:32:08 PST 1996
    sms1 at sms.sms.iipo.gtegsc.com:/usr/src/sys/GENERIC

phys mem  = 3932160
avail mem = 3719616
user mem  = 307200

February 29 23:09:36 init: configure system

rk ? csr 177400 vector 220 skipped:  No autoconfig routines.
rl 0 csr 174400 vector 160 attached
erase, kill ^U, intr ^C


And that's it!!
I have commented out the RK entries in /etc/fstab as I certainly don't
have any real RK disks.  :-)

Next, I usually do:
# mount -a
/dev/rl2a on /vol2: No such device or address

And so it goes.

I should probably mention again, these are the 2.11_on_rl02 images from
the archive.  It consists of 4 RL02's and 6 RK's and it boots and runs
fine under SIMH.

> Second, do you have the entries in /dev?

Maybe I'll try running MAKEDEV just to be sure there isn't something
corrupted, but being as the boot disk and vol1 both transfered and
copyed to real packs OK I have no reason to suspect there is anything
wrong with the data on the pack.  Hmmmmm... Maybe I'm just paranoid,
but I don;t think I will make this assumption.  I think I will make
a new vol2 pack anyway.

But that still leaves why I see no RA's either.

Any more suggestions?

Is there anyone running a webserver on a PDP-11??  Or will I be the
first when I get this going??  I was going to do it with Ultrix-11
but I think it may be easier to get up and definitely more stable on
2.11BSD.  Ultrix-11 still needs more work getting it back up to real
production quality. (But I plan on doing it!!)

All the best.


Bill Gunshannon          |  de-moc-ra-cy (di mok' ra see) n.  Three wolves
bill at cs.scranton.edu     |  and a sheep voting on what's for dinner.
University of Scranton   |
Scranton, Pennsylvania   |         #include <std.disclaimer.h>

More information about the TUHS mailing list