[pups] 2.11 on an 11/44

Steven M. Schultz sms at 2BSD.COM
Fri Feb 28 03:06:13 AEST 2003

Hi -

> From: Bill Gunshannon <bill at cs.scranton.edu>
> I am trying to put 2.11 on one of my 11/44's.  I picked up the RL02/RK
> images from the archive.  I put the RL02 images on real RL02's (Yes,
> some of us still have and use them!! :-)  My intent was to boot this

	RL drives were reliable (compared to RA81 and RK06/7 drives) if not 
	exactly spacious ;)

>   3 RL02 disks
>   A CDU/720-TM SCSI Controller with 4 MAXTOR 340M disks and a QIC tape
> Now the problem.
> The system boots fine.  And it will mount /dev/rl1a.  But it won't mount
> /dev/rl2a.  I get "/dev/rl2a on /vol2: No such device or address".

	What rev of the kernel do you have?   First line in /VERSION should
	have the magic number.

> I get the same error when I try to do a disklabel.  What's more, I also
> get this same error when I try to access any of the RA devices.  I am
> using the GENERIC Kernel which I assume has all the devices in it.
> Anybody have any suggestions??
	What I think is happening is that the system is only configured for
	2 RL drives - the change from 2 to 4 happened quite late (patch #439
	I think).

	The RA problem sounds like the MSCP driver either isn't in the
	kernel or wasn't probed/attached at boot time.     You can see if
	MSCP support's present with something like 'nm -g /unix | grep _raintr"
	and seeing if you "040364 T _raintr" for the interrupt handler.   If
	you do get that then check /etc/dtab for a line like:

ra      ? 172150 0      5       raintr          # uda50, rqdx1/2/3

	The '0' for the vector says for the probe/attach logic to assign
	a vector and tell the controller what value was used.  You could put
	anything in there (154 or 150 I think is the assigned value for the
	first MSCP controller).

	If none of that works then I'm stumped as to why the RA drives can't
	be accessed.

	Good Luck.

	Steven Schultz

More information about the TUHS mailing list