[pups] 2.11BSD device config trouble

Jochen Kunz jkunz at unixag-kl.fh-kl.de
Thu May 1 02:23:49 AEST 2003

On 2003.04.30 15:40 David Evans wrote:

>   I didn't see my other post go through; 
I got it only via private mail.

> have you tried adding some comments
> to the end of this line?  Perhaps the autoconfig parser becomes
> confused if there aren't any.
I added comments at the end of the lines and now it works:

April 30 17:29:29 init: configure system

dhv ? csr 160440 vector 310 didn't interrupt.
ra 0 csr 172150 vector 154 vectorset attached
ra 1 csr 160334 vector 764 vectorset attached
rx ? csr 177170 vector 264 skipped:  No CSR.
tms 0 csr 174500 vector 260 vectorset attached
ts 0 csr 172520 vector 224 attached
cn 1 csr 176540 vector 344 attached
cn 2 csr 176550 vector 354 attached
cn 3 csr 176560 vector 364 attached

Hmmm. No manpage for cn/dl/kl? Major / minor device numbers?
[reading the kernel source]
Aha. /dev/ttyl1 is what I am looking for. But the interrupt vector seams
to be wrong. 

But still trouble with the dhv. Maybe wrong interrupt vector too? Maybe
I compile a kernel with support for a DZQ11... 

> > But I would prefere to get the DHV11 working. It seams that this
> > device is more suitable for multi user operation. 
>   Mine is at least correctly identified by autoconfig, though I've
> never attached a terminal to it to see whether the ports actually do
> anything.
Normaly I use the console for booting only and then I telnet to the
machine. But I wane connect some terminals to the PDP-11 at the VCFe, so
the visitors can log in play around. 

[fsck trouble]
>   Is the disk write-inhibited?
No. It seams that I made the mistake to reboot using reboot(8) insted of
power cycling the machine when fsck modified the file system. Didn't
notice that / was mounted r/w. 


Homepage: http://www.unixag-kl.fh-kl.de/~jkunz/

More information about the TUHS mailing list