[TUHS] TUHS Digest, Vol 33, Issue 2

Madcrow Maxwell madcrow.maxwell at gmail.com
Fri Aug 11 23:25:07 AEST 2006

Hmm, it doesn't seem to work. I run the following script:

# This shell script builds a full ULTRIX-11 V3.1 master
# distribution tape on a TK50 boot tape image. It
# is based on a tape dump provided by Wilko Bulte, and
# maintains all original files.
# Author: Fred N. van Kempen <fred at microwalt.nl>
#         ... with the support of many, now and in the past.
# Modified by: Michael "Madcrow" Kerpan <madcrow.maxwell at gmail.com>
# Several of the included tools were either developed by
# others trying to read or create tapes, or come from the
# ULTRIX-11 source distribution kit.


  echo Creating ULTRIX-11 V3.1 Master Distribution on TK50.
  echo "----------------------------------------------------"
  echo ""

  if [ ! -f ./maketape ]; then
        echo Compiling MAKETAPE tool...
        gcc -o ./maketape src/maketape.c

  if [ ! -f ./tdtk50.bv ]; then
        echo 'Generating the Tape Definition file (for TK50)...'
        cp src/tdtk50.bv ./tdtk50.bv

  if [ ! -f ./filesep ]; then
        echo 'Generating the Tape File Seperator...'
        dd if=/dev/zero of=./filesep bs=1 count=4

  # Create the first tape file with uboot, boot and /sas.
  echo Creating boot record on tape...
  ./maketape ./step1 ./tdtk50.bv

  # Add the rest of the tape stuff and create the final image
  echo Generating tape image
  cat ./step1 ./filesep fs/md-sas.dsk ./filesep data/file14 ./filesep
data/file15 ./filesep data/file16 ./filesep data/file17 ./filesep
data/file18 ./filesep data/file19 ./filesep data/file20 ./filesep
data/file21 ./filesep data/file22 ./filesep data/file23 ./filesep
data/file24 ./filesep data/file25 ./filesep data/file26 ./filesep
data/file27 ./filesep data/file28 ./filesep data/file29 ./filesep
data/file30 ./filesep data/file31 ./filesep data/file32 ./filesep
data/file33 ./filesep data/file34 ./filesep data/file35 ./filesep
./filesep > $TAPE

  echo ""
  echo "---------------------------------------"
  echo All done !

and get a file of 37939812 bytes, but when I try to boot it in SIMH I
get the same error as before. Could the tape header and initial
records as generated by "maketape" be faulty? The step1 file generated
by maketape is only 45568 bytes and I get the following warnings from
gcc (version 4.1.0) during the maketape compile:

src/maketape.c: In function 'main':
src/maketape.c:28: warning: incompatible implicit declaration of
built-in function 'exit'
src/maketape.c:32: warning: incompatible implicit declaration of
built-in function 'exit'
src/maketape.c:36: warning: incompatible implicit declaration of
built-in function 'exit'
src/maketape.c:43: warning: incompatible implicit declaration of
built-in function 'exit'
src/maketape.c:73: warning: assignment from incompatible pointer type

Any help would be much appreciated.

Mike "Madcrow" K.

More information about the TUHS mailing list