[TUHS] Can't load split I&D files (in one PDP-11/23 PLUS)

Pete Turnbull pete at dunnington.plus.com
Fri Jun 26 07:26:06 AEST 2009

On 25/06/2009 21:49, Wilko Bulte wrote:
> Quoting SPC, who wrote on Thu, Jun 25, 2009 at 08:57:47PM +0200 ..
>> Well, the matter is simple: I'm trying to install 2.11 BSD in one PDP-11/23
>> PLUS with 4MB of ram, and the 'restor' and 'icheck' utilities don't load in
>> he PDP, returning this message:
>>   "Can't load split I&D files"
>> I tried with the diverse distributions of Vtserver and diverse versions of
>> 'restor'. In the case of the 2.9BSD this don't happen but the utility can't
>> understand what is the 'vt' device.
>> Someone has encountered and solved this problem ?
> I could be wrong, but I think the 11/23 is not a split ID CPU?

Correct, it isn't.  You cannot run 2.11BSD in a PDP-11/23 or similar 
machine because a lot of things in 2.11BSD require split I&D.  It's 
declared on the first page of the setup instructions:

    "This distribution can be booted on a PDP-11 with 1Mb of memory or
     more, separate I&D, and with any of the following disks:"

You need an 11/73 or better to have split I&D.  For those who might not 
know what that means, it refers to the processor's ability to keep 
I(nstructions) and D(ata) in separate spaces, so in effect virtually 
doubling the amount of memory that can be used.  That is, you can have 
(almost) 64K of instructions *and* (almost) 64K of data at the same 
time.  Without split I&D, you have 64K in total for both.

Pete						Peter Turnbull
						Network Manager
						University of York

More information about the TUHS mailing list