[TUHS] DG/UX user/admin around?

Natalia Portillo claunia at claunia.com
Wed Aug 25 01:34:51 AEST 2010

Use lspci -v on the Linux LiveCD to be sure that bus, slot, function and controller number are correct.

El 24/08/2010, a las 15:44, DG UX escribió:

> I've tried 3 things:
> 1. Board shows "PCI3"
> 2. Linux LiveCD says PCI slot 3
> 3. I've tried a million combinations, just for the heck of it. None worked.
> And also, as I said, in case there is only 1 adapter it should
> automatically default and I cant shorthand it, as -
> sd(apsc(pci(),3),0)root
> Of course that as for the controller ID it is 7 - as shown by the
> Adaptec management tool and the device ID is 1 (or 0), depending on
> where I put it's jumper and also shown by mgmt tool at boot.
> Got any other ideas of how to verify bus/slot?
> On Tue, Aug 24, 2010 at 4:01 AM, Natalia Portillo <claunia at claunia.com> wrote:
>> Hi,
>> Just a question.
>> How did you checked the PCI bus and slot numbers?
>> Counting physically on the motherboard?
>> If this is the case you're doing it wrong.
>> The chipset could have various buses and slot numbers and so what appears physically to be slot 0 can easily be bus 2 slot 6.
>> El 11/08/2010, a las 15:14, DG UX escribió:
>>> Sorry to bother you all with my questions over this ancient machine
>>> and my failing trials with it..
>>> Trying to get a DGUX system (Intel based) to work, as is, on a 'regular' x86 PC.
>>> Just a couple of things :
>>> 1. I did find out that that DG machine is looking for an Adaptec PCI
>>> SCSI Controller, and so I got an AHA-2940UW PCI card, installed it in
>>> an old PC, got a matching 9GB HDD and booted it up from my image I've
>>> 'DD'ed from the original DG machine.
>>> Boot prompt came up and said it's trying to load
>>> sd(apsc(pci(0),d,0,7),1,0)root:/dgux -3
>>> it didn't, no error msg, just gave me back a "Boot command:" prompt.
>>> Bootpath of the original machine is sd(apsc(pci(0),d,0,7),1,0)root:/dgux -3.
>>> The disk drive parameters are correct, according to the docs, its -
>>> dev(ctrl(pci[pci_num]),slot[,func_num[,ctrl_id]])[,dev_id[,LUN]]).
>>> I've checked the PCI slot in which I installed the card, it's 3, and
>>> so I've tried '3' instead of 'd' in the command above, just got the
>>> boot prompt back again.
>>> Also tried - sd(apsc(pci(),3),0)root:/dgux -3  which should also work
>>> according to the docs (all other params are default).
>>> Tried to play with it and tried tons of combinations, just for the
>>> heck of it, still nothing. If I do type in some nonsense it does give
>>> me an error msg : "Error: No device specifications found in the boot
>>> command. Invalid boot command line".
>>> According to the docs, once I get the correct syntax, the system should load up.
>>> Anyone got any advice about that?
>>> 2.   Anyone here a/was a DG/UX user/admin? you guys are very hard to find :)
>>> Thanks,
>>> D'
>>> _______________________________________________
>>> TUHS mailing list
>>> TUHS at minnie.tuhs.org
>>> https://minnie.tuhs.org/mailman/listinfo/tuhs

More information about the TUHS mailing list