[pups] PDP-11 (SIMH), Seventh Edition UNIX

Johnny Billquist bqt at softjar.se
Wed Sep 29 19:24:30 AEST 2010

Mark Tuson wrote:
> Hi everyone, this is my first message, after being on the mailing list 
> for the best part of three years :)
> I've a couple of [hopefully] simple questions about running Seventh 
> Edition UNIX on SIMH.

Oh joy! :-)

> The first question is: how can I get the C compiler to work properly? 
> When I've tried to compile programs, I get 'cannot create temp' - here's 
> a full list of what's on the screen:
> @boot
> New Boot, known devices are hp ht rk rl rp tm vt
> : rl(0,0)rl2unix
> mem = 177856
> # Thu Sep 22 07:50:47 EDT 1988
> login: mark
> $ ed
> a
> main() {
>   printf("  Hello.\n");
>   return; }
> .
> w a.c
> 46
> q
> $ cc a.c
> cc: cannot create temp
> $

As others have mentioned, it could be problems with /tmp protection, as 
well as checking if there actually is any free space there.

> Also, how can I get the backspace key to erase? I've done /stty erase 
> '^H'/ but I have to actually type <CTRL>+H to erase.

You need to know what code the key you call "backspace" actually sends. 
I suspect it is not sending a backspace, but a DEL (DEL is actually the 
traditional character used to delete, BS is a modern perversion).

> The other thing I want to ask about is: can I compile SIMH on DOS, so it 
> doesn't display any messages except those of the simulated software, and 
> so it ignores ^E?

For the messages, I'm not sure what you are thinking of. Is it the ones 
before boot time, or is there some other messages that you see?

As for the ^E, that is configured in simh when running.

> I'm asking because I want v7 on an ancient laptop I've got lying around 
> - a 486 with 24M of core. v7x86 won't work on it, and I don't really 
> fancy putting Slack 3 back on it - if I'm going to go outdated, I might 
> as well go the whole hog and go /really/ outdated.


> Though I might consider 2.11BSD, if that'll work on a machine with 24M 
> of core, and if the escapes will display properly, because
> [24;1H[?1h=[;H[2J
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~
>                  ~[H
> is a little bit difficult to work with when I'm wanting to edit source code.

2.11BSD won't make a difference. You'll see the same result. This is a 
problem because you are running under DOS. It is the DOS screen handler 
that needs to understand whatever codes are output by the programs 
running inside simh. In this case, the program inside simh thinks it is 
connected to a VT100 (or xterm, or something similar), and sends escape 
codes based on that. I don't know why it thinks so, but I suspect you 
told the system by setting the TERM variable. Please set it to something 
that matches reality, or else fix reality. :-)


More information about the TUHS mailing list