Project generate RL02.

Beastly Wolf beast at
Tue Feb 24 18:05:36 AEST 1998

Hi again gang!

It looks as if we can turn the binaries in PUPS's archive into hardware
with dd, as my theory went.
So I went forth and started to tinker a bit with my trusty old ULTRIX rig.
I run into some problems though and before starting to fiddle with them
myself, I thought I should ask out there if this is a known caveat.

Here goes:
My uVAX has an RQDX-3 controller, a controller for EAGLE disks, TQK50,
DQNA and some sort of line card (A DHV-11 I think).
I added an RLV-controller for those RL02 drives into the system and
snipped some rows from the GENERIC file to make a good system.
What struck me as if upon my head was that the CSR for the DQNA and the
RL02 controller was the same.
Vector is set by some intricate mechanism automagically though.

Oh well, I maked the kernel and it booted fine. If found the hl device
BUT! It also said (twice!) that the hl device did not interrupt.

I do not have a drive connected though.
I tried both with and without external terminator on the drive connector.
No go. Same message.

I am reluctant to put cards on non standard CSRs since the GENERIC kernel
will not operate as intended and boy are those GENERIC kernels good to have!

So here is the problem:
What the heck is happening? Do I need to have the RL02 connected to get the
darn thing to interrupt or do I have a CSR / Interrupt conflict along the 
Or could the controller be bad? (Not to worry! I got more controllers
laying about! =) ).

If nobody got answers to this my next experiment will be to take out the
DQNA and see if that helps. I am reluctant to fiddle to much with the
cards since the machine is installed in a non standard 19" CRAMMED FULL
kinda rack and is hard to service.


Received: (from major at localhost)
	by (8.8.5/8.8.5) id BAA03167
	for pups-liszt; Wed, 25 Feb 1998 01:47:58 +1100 (EST)
X-Authentication-Warning: major set sender to owner-pups at using -f

More information about the TUHS mailing list