KA650 problem

Michael Sokolov mxs46 at k2.scl.cwru.edu
Fri Nov 20 12:09:52 AEST 1998

   Dear Ladies and Gentlemen,
   I'm trying to build my first release (4.3BSD-Quasijarus1), and I have
the following problem. I'm currently away from my main VAX farm, and so I
have rounded up a new VAX for this task from an independent source. It's a
KA650-based MicroVAX specially made for Xerox. The outer cabinet is made by
Xerox, but it has a BA23 mounted inside. There is no video, just a serial
   My first problem was that the beast refused to power up. I turn on the
power, but there is nothing on the console and the hex LED display on the
back says 9. I power-cycled it several times with zero effect, and then I
took the CPU board out to look at it. It looked perfectly normal, and I put
it back in. Then imagine my joy when I power up the VAX and this time it
works! After that I worked with it for a while, and in the process I turned
it on and off a couple of times and it didn't have any problem powering up.
   My next step was installing Ultrix, which is the platform I have chosen
to use for putting together the initial Quasijarus SCCS tree and cross-
compiling the very first Quasijarus build. However, when I tried to boot
from the Ultrix tape, I got a "?4B CTRLERR" (after an _extremely_ long wait
with a lot of retries), which according to my docs means some hardware
error. I reasoned that it has to be either the TK50 drive or the TQK50
controller. I don't have any spare TK50s at this location, but I do have
one spare controller, and so I tried swapping it. I turned the machine off,
swapped the board, and turned it back on. And guess what, that ugly 9 came
back! I haven't been able to power up the VAX since then.
   I started investigating. I don't have any docs for KA650, but I do have
some for KA655. According to these docs, the KA650 series CPUs have very
elaborate ROM diagnostics organized in the form of scripts, some of which
are executed at power-up. The manual lists all scripts, indicating the
order of the tests and the hex LED display codes. According to this manual,
the only tests which display a 9 are fairly late in the sequence and are
fairly benign (shouldn't stall the power-up even if failed). The problem
I'm seeing, OTOH, appears to be very early. For example, the console line
loopback test appears to be one of the very first, and yet my VAX always
stalls on the 9, even if I put the switch in the T-in-the-circle position.
I have also watched the hex LED display very carefully right as I flip the
power switch, and as far as I can tell it goes directly from F (waiting for
DCOK) to 9. Finally, disconnecting the bulkhead and the memory interconnect
produces absolutely no effect, suggesting that the culprit is the CPU board
and nothing else. Also pushing the RESTART button on the front panel
produces absolutely no effect, if the 9 was there it just stays there,
there is no F appearing for a short time or anything like that. What does
the RESTART button do, anyway?
   Does anyone here have a clue as to what's going on? Does anyone have a
KA650 manual? Can anyone tell what the hell does the 9 stand for? Any ideas
on how this can be fixed (other than replacing the CPU board)? TIA.
   Michael Sokolov
   Phone: 440-449-0299 (Home) 216-217-2579 (Cellular)
   ARPA Internet SMTP mail: mxs46 at k2.scl.cwru.edu

Received: (from major at localhost)
	by minnie.cs.adfa.edu.au (8.9.1/8.9.1) id TAA06383
	for pups-liszt; Fri, 20 Nov 1998 19:08:01 +1100 (EST)
	(envelope-from owner-pups at minnie.cs.adfa.oz.au)
X-Authentication-Warning: minnie.cs.adfa.edu.au: major set sender to owner-pups at minnie.cs.adfa.oz.au using -f

More information about the TUHS mailing list