[pups] File exchange with Supnik sim

Richard Donkin rdonkin at bigfoot.com
Thu Feb 1 08:42:02 AEST 2001

I've tried the suggestions for getting files in and out of the Supnik
in particular using rl0 mapped to x.tar, and 'tar cvf /dev/rrl0a
However, tar complains: 'tar: tape write error: Read-only file system'.

The disklabel for rl0 looks like:

# /dev/rrl0a:
type: old DEC
bytes/sector: 512
sectors/track: 20
tracks/cylinder: 2
sectors/cylinder: 40
cylinders: 0
rpm: 0
interleave: 0
trackskew: 0
cylinderskew: 0
headswitch: 0           # milliseconds
track-to-track seek: 0  # milliseconds
drivedata: 0 

1 partitions:
#        size   offset    fstype   [fsize bsize]
  a:    10240        0   2.11BSD     1024  1024         # (Cyl.    0 -
cylinders/unit 0
Warning, revolutions/minute 0
boot block size 0
super block size 0
partition a: extends past end of unit 0 10240 0

Presumably I need to create a valid disklabel, but it would be good to
have some advice on what a valid one
would look like.

I've also tried the same sort of thing with 'tar cvbBf 20 /dev/rmt0
/etc/hosts', and 
something like a tar file is produced - however, GNU tar on Linux and
FreeBSD 4.2 tar can't
read this, saying 'this doesn't look like a tar file'.  Is there some
trick to getting this
to work, and am I better off using rl0 or rmt0? 


Received: (from major at localhost)
	by minnie.cs.adfa.edu.au (8.9.3/8.9.3) id KAA33243
	for pups-liszt; Thu, 1 Feb 2001 10:16:28 +1100 (EST)
	(envelope-from owner-pups at minnie.cs.adfa.edu.au)

More information about the TUHS mailing list