[pups] A bootable disk image for a PDP-11/34?

Carl Lowenstein cdl at mpl.ucsd.edu
Fri Feb 2 03:35:13 AEST 2001

> From iking at microsoft.com Tue Jan 30 15:27 PST 2001
> From: Ian King <iking at microsoft.com>
> To: "'Ken Wellsch'" <kwellsch at tampabay.rr.com>,
>         Carl Lowenstein
> 	 <cdl at mpl.ucsd.edu>
> Cc: pups at minnie.cs.adfa.edu.au
> Subject: RE: [pups] A bootable disk image for a PDP-11/34?
> Date: Tue, 30 Jan 2001 14:38:15 -0800
> Ken, I tried using that image and gunzip told me there was a crc error; it
> wouldn't unzip it.  (I downloaded it three times, just in case there was a
> transmission error -- twice by ftp, once by http.)  I've also tried the
> "Dennis" images, which are supposedly straight RK05 images; E11 won't boot
> 'em.  One issue on which I'm not clear: where is the boot address?  Stuff at
> loc 0 doesn't look like boot instructions.  
> If I could get an image to run in an emulator (as I mentioned, I'm running
> E11 from DBit), I'd write some cheesy little loader to bring it down the
> serial line (I already have it sketched out); but until I can at least get
> one to boot in the emulator, I'm reluctant to spend the hours (at 9600 baud)
> to spray it onto a disk.  <sigh>  

Well, as some response to this challenge "get an image to run in an emulator",
I visited Bob Supnik's Computer History Simulation Project web page


and followed the links to the sources for SIMH v2.5a and to the Unix V6
disk images.

I read the documentation file "simh_doc.txt", and compiled the
simulator.  Then I read "simh_swre.txt", unpacked the V6 images, ran
the simulator and attached the three RK05 images to it, and booted
RK0.  All according to the instructions.

I got the bootstrap prompt "@" to which I typed "unix" and it came up
with a "login:" prompt, to which I could log in as root, and do things.

It's not quite the same V6 image that I remember from the olden days of
loading onto an 11/40 from magtape.  The login prompt seems not to be
";login:" as we still see on the Usenix magazine.  dmr's account seems
to have vanished but ken's is still there.  And that's how I spent a
few hours last night.

In case it matters, the underlying hardware/software platform is an AMD
K6-3 running Mandrake 7.1 Linux.


        carl lowenstein         marine physical lab     u.c. san diego
        {decvax|ucbvax} !ucsd!mpl!cdl                 cdl at mpl.ucsd.edu
                                                  clowenstein at ucsd.edu

More information about the TUHS mailing list