[pups] BSD 2.11 SL/IP and sim2.3d+BB1

PUP jstevep at tron.superglobalmegacorp.com
Thu May 17 12:31:48 AEST 2001

	I know that there must be some setup guides for BSD2.11 still floating around there, but I have not been able to find anything.. Here is what I am trying to do:

	I noticed that the sim2.3d+BB1 emulator will allow you to connect Unix "devices" to the DL1 lines.  I set it to connect the serial port on my Linux box, and connected a IBM 3151 (VT100 like terminal), and it worked great!  Taking this a step further, I took the serial port and moved it to my Cisco router (the aux port).. I have been trying to configure SL/IP on it.. I first setup my Linux box to connect to the router via slip so that I can verify my cisco config.  I am having trouble on the BSD side.. As far as I can tell it is not routing replys over the sl0 interface.. (Or the emulator is cooking the serial data...)  A final test I tried to connect to copies of sim2.3d+BB1 via pty's.. same thing.  The good part is when you try to telnet from the router, you can see the socket accept on the BSD side.. The BSD box seems not to reply..  Additionally I saw some  stuff on increasing the size of CBLOCK in param.h (my default was 32, I tried 64), which seemed to have no effect.

I started SL/IP by running 
slattach ttyl1 9600

ifconfig sl0 up

by default as this I can't ping the (my side).. so I added a route

route add 0

I don't know if I have to do this...  Oh the image that I'm using is the 2.11_rp_unknown from the archive.. (It has a note that it is patch level 400.)  Also the person that maintains BSD 2.11's site is down.. bummer..

Sorry for the rambling!

Received: (from major at localhost)
	by minnie.tuhs.org (8.9.3/8.9.3) id OAA96454
	for pups-liszt; Thu, 17 May 2001 14:04:16 +1000 (EST)
	(envelope-from owner-pups at minnie.cs.adfa.edu.au)

More information about the TUHS mailing list