[pups] Installing begemot

Robin Birch robinb at ruffnready.co.uk
Fri Aug 13 06:29:48 AEST 2004

In message <411BBDD3.3050400 at sun.com>, Chris Drake <chris.drake at sun.com> 
>I'd be interested in seeing your results and final analysis for begemot.
>I tried (briefly) getting it to run and gave up.  Post 'em!
>> I have a different problem as well.  There is something broken in the 
>>configuration of this computer!!!!!  If I execute a shell file by 
>>going /bin/sh filename then it works ok but if I try running a shell 
>>script  with #!/bin/sh in the first line I get a bad permission error.
>Starting with the simplest possibility --  if you run "sh filename", all
>you need are read permissions on the file.  If you run "filename" with the
>#!/bin/sh in the first line, the filename itself needs to have execute
>permissions enabled.
>Try  chmod a+x filename  and see if that helps.
>If that's not the issue, then more detail on the error message would be
>good.  There are tons of different messages and if you don't get the exact
>right one when you're trying to debug, you can go down lots of wild rat 
>       - Chris
Hi Chris,
The most curious one is a "bad interpreter" one.  This is what I get 
along with the permissions moan.  But curiously if I run it sh filename 
then all works.

It is as though there is some global shell permissions set up that is 

Robin Birch

More information about the TUHS mailing list