Installation of 2.11BSD (II)

Greg Lehey grog at
Wed May 6 17:07:10 AEST 1998

On Wed,  6 May 1998 at 16:38:21 +1000, Warren Toomey wrote:
> In article by Matthias Bruestle:
>> I'm using 2.11_rp_unknown[1] an the newest version of the supnik emulator.
> 	[that's in the PUPS Archive, for those without a src license]
>> When I'm compiling a kernel (with the newest 2.11BSD sources), I get
>> [problems]
>> I configured the emulator with 1MB RAM. I compiled it with and without
>> optimization. Is this a problem with the distribution, with the emulator
>> or with the compiler [used to build the emulator?] (gcc
>> The "distributed" 2.11BSD is not so stable. It is often killing the
>> filesystem.
> Hmm, Steven Schultz did find yet another bug in Bob's emulator which fixed
> the crashing vi problem. As Steven knows heaps more about 2.11 than I, here
> are some general purpose suggestions from me.
>> Manually fsck on bootup. Does that help prevent fs corruption,
> 	  or is the system killing the filesystem on a regular basis?
>> Can you build a GENERIC kernel? Does it boot?
>> The 2.11_rp_unknown disk image was built with the new P11
> 	  emulator from the Begemot crew. You might try compiling and
> 	  installing this emulator, and see how 2.11BSD performs.
> Anyway, Steven might offer some better advice! Greg Lehey might be able
> to provide you with the P11 config files he uses. I've got the new P11
> built at home, but I can't get the files on it from work.

Well, I started an answer, and decided that Steven would be able to
answer better, but since you mention my name, OK, here I am.

One point:

> Is this a problem with the distribution, with the emulator or with
> the compiler (gcc

First, the compiler is certainly not gcc.  That would never fit in the
address space of a PDP-11.  Secondly, I'd guess it's the emulator.  I
don't think many people have tried 2.11BSD on the Supnik emulator.

I'm using the Begemot emulator (Emulators/P11-2.3 in the archive).  I

[5] root--> cd /usr/src/sys/GRANDPA/
[6] root--> ./checksys unix
System will occupy 295600 bytes of memory (including buffers and clists).

               end {0122636}          nbuf {0013562}           buf {0053542}
             nproc {0013550}          proc {0077060}         ntext {0013552}
              text {0121416}         nfile {0013556}          file {0115726}
            ninode {0013554}         inode {0013646}      ncallout {0013560}
           callout {0044274}     ucb_clist {0013566}        nclist {0013564}
          ram_size {0000000}       xitdesc {0013644}      quotdesc {0000000}
         namecache {0053150}       _iosize {0000000}
[7] root--> 

I won't pretend that the documentation of the interpreter is ideal,
nor that it's easy to set up.  It took me quite a while.  Take a look
at the files in  They are:

-rw-r--r--  1 root  lemis  11477 May  6 16:18 README-emu
-rw-r--r--  1 root  lemis   1746 May  6 16:18 p11conf
-rwxr-xr-x  1 root  lemis    315 May  6 16:19 run_211

README-emu is a brief (and hurried) description of what I did to get
the emulator working, p11conf is my current configuration, and run_211
is the command file I run to actually start the emulator.  Note that
what you get when you run the emulator is just the diagnostic console;
to actually use the machine, you need to telnet to ports 10000 to
10003.  Anybody interested in so doing can telnet to
and log in as guest, password "Today only".  Don't break anything,
please--I haven't checked security too much.

See complete headers for address and phone numbers
finger grog at for PGP public key

Received: (from major at localhost)
	by (8.8.8/8.8.8) id AAA08014
	for pups-liszt; Thu, 7 May 1998 00:38:54 +1000 (EST)

More information about the TUHS mailing list