[pups] 2.11BSD boot hangs.

Steven M. Schultz sms at moe.2bsd.com
Tue Feb 27 04:22:23 AEST 2001

Hi -

> From: jkunz at unixag-kl.fh-kl.de
> Yesterday I installed 2.11BSD on my PDP11/73. Everything went fine up
> to the first time when UNIX was booted. The kernel came up, init was
> started, autoconfig run and printed out the devices it had (not) found.

> 2.11 BSD UNIX #115: Sat Apr 22 19:07:25 PDT 2000
>     sms1 at curly.2bsd.com:/usr/src/sys/GENERIC

	That looks good - and familiar ;)

> xp ? csr 176700 vector 254 skipped:  No CSR.
> -----
> it hangs. Characters I type into the terminal are echod, but nothing

	The next thing that should have come out is the '# ' single user

> else happens. The "Run" LED at the front panel is off. I tried with an

	That sounds like the system 'halt'ed for some (unknown) reason.

	Sigh - that kernel should work fine, especially with a RQDX3/RD54.  I
	am at a loss to explain/diagnose the problem.

> System configuration:
> 11/73 (M8192), one with FP accel. or one without. (Jumpers W1..W6 in,
> W7..W9 out, so that the CPU enters ODT at power up.)

	There is a jumper (I forget which one) that enables/disables the
	'halt' instruction.  If 'halt' is disabled then the 'halt' instruction
	is treated as a 'nop' even in kernel mode.  If 'halt' is enabled then
	the console ODT will be entered if the kernel executes a halt.

	Looks like we'll have to try and solve this the hard way ;(

	After the system hangs press the 'halt' button on the front of the
	machine and note the PC - hopefully that value will give a clue as
	to where the kernel is at the time (likely in a clock interrupt).

> BTW: What serial parameters does 2.11BSD use? The first time I booted
> UNIX I got garbage after "user mem  = 307200". I seted the vt220 to 7e1
> and this worked, but is it correct?

	Yes, 7e1 is correct - a legacy setting from eons ago.

	Steven Schultz
	sms at moe.2bsd.com

More information about the TUHS mailing list