[pups] A bootable disk image for a PDP-11/34?

Ian King iking at microsoft.com
Wed Jan 31 17:05:55 AEST 2001

Ken, if you send it to my personal email account, there's no size
restriction (I run the mail server); it's iking at killthewabbit.org.  I would
greatly appreciate your sending it to me.  BTW, I've been using 1977 (the
year I graduated fron high school) on my PDP-11 under RSX-11; some tools
won't accept the "01" year.  :-)  

Cheers -- isk 

PS: I've hired a lot of Waterloo folks -- smart buggers, the lot of them.

-----Original Message-----
From: Ken Wellsch [mailto:kwellsch at tampabay.rr.com]
Sent: Tuesday, January 30, 2001 3:28 PM
To: Ian King
Cc: pups at minnie.cs.adfa.edu.au
Subject: Re: [pups] A bootable disk image for a PDP-11/34?

Hi Ian,

Indeed, looks like there has been some bit rot on the archive... sigh.

Luckily I am a pack rat and have copies of my Waterloo days data.  The
images are all clean there.  Curiously enough I even found the directory
where I ran that simulation (circa Oct/94 I see).  I just rebuilt the
code there and ran it on my NetBSD/i386 system and it boots V6 just fine.

In case you don't read minds, after doing the 'attach ...' then 'boot rk0'
the intuitive V6 boot prompt '@' is where you type 'rkunix' for example B^)

Almost instantly I had a 'login:' prompt, and the image is off the tape
so there is no root password set...

Don't forget to type 'date' when logged in ... it is a hoot to see B^)

Oh heck, never thought to actually try to set the date, post 2000...
maybe better to let it live back in 1975...

I've tar/gzip'ed the bundle.  Do you want me to try and UUencode it
and mail it to you?  It is nearly 1 Mbyte in binary form...

Oh yeah, as Warren mentioned, stock V6 does not run on a '34.  I think
it ran on a '40.  I know it can run on a '34 because in 1980 I started
using UNIX, V6 running on a '34  B^)


-- Ken

Ian King wrote:
> Ken, I tried using that image and gunzip told me there was a crc error; it
> wouldn't unzip it.  (I downloaded it three times, just in case there was a
> transmission error -- twice by ftp, once by http.)  I've also tried the
> "Dennis" images, which are supposedly straight RK05 images; E11 won't boot
> 'em.  One issue on which I'm not clear: where is the boot address?  Stuff
> loc 0 doesn't look like boot instructions.
> If I could get an image to run in an emulator (as I mentioned, I'm running
> E11 from DBit), I'd write some cheesy little loader to bring it down the
> serial line (I already have it sketched out); but until I can at least get
> one to boot in the emulator, I'm reluctant to spend the hours (at 9600
> to spray it onto a disk.  <sigh>
> Any suggestions you may have would be greatly appreciated.  -- Ian

Received: (from major at localhost)
	by minnie.cs.adfa.edu.au (8.9.3/8.9.3) id AAA29613
	for pups-liszt; Thu, 1 Feb 2001 00:21:49 +1100 (EST)
	(envelope-from owner-pups at minnie.cs.adfa.edu.au)

More information about the TUHS mailing list