[pups] 2.11 on an 11/44

Robin Birch robinb at ruffnready.co.uk
Sun Mar 2 07:36:05 AEST 2003

I haven't got a live 2.11 system anywhere near but the following occurs 
to me.

1) I think that the GENERIC kernel only has 2 RL02s configured and will 
expect these on device selects 0 and 1.  The idea is to get the generic 
going and then rebuild for your specific config.

2) Are all of your RL02s on one controller?.  If not then two things 
occur. The first is that I think the GENERIC kernel is only configured 
for one controller.  Secondly, if the second drive is on the second 
controller then the physical select will probably be 8 and the device 
will probably be rl8a.

3) If the SCSI controller emulates an MSCP device then I think that 2 
MSCP discs are configured for the GENERIC kernel.  Again, if you need 
more then you will need to rebuild the kernel.

Although the generic kernel is configured for a lot of devices they will 
not necessarily be attached if the appropriate file in /etc doesn't have 
the rems taken out.  Can't remember the file name but that will need the 
appropriate controllers to have the rems taken out.

I assume that you can mount rl0 and rl1 from your note.  Load the kernel 
sources onto these two discs, You should be able to get everything 
except the usr src onto the two rl02s.  Then create a kernel that has 
only the devices that you need and then you should see everything that 
you have.

The autoconfig system is not as informative as newer OS's but it will 
tell you if something is detected that the kernel is configured for.  If 
it exists but the kernel knows nothing about it then autoconfig will not 
display it.

If I am attempting to teach my grandmother to suck eggs then forgive me.



In message <20030227093041.Y43050-100000 at server1.cs.uofs.edu>, Bill 
Gunshannon <bill at cs.scranton.edu> writes
>I am trying to put 2.11 on one of my 11/44's.  I picked up the RL02/RK
>images from the archive.  I put the RL02 images on real RL02's (Yes,
>some of us still have and use them!! :-)  My intent was to boot this
>and then use it to build a system on a bigger disk and then go on from
>Here's my configuration:
>  11/44 CPU
>  CIS
>  EIS
>  FP11
>  4M memory (actually 3840KB)
>  MMU
>  3 RL02 disks
>  A CDU/720-TM SCSI Controller with 4 MAXTOR 340M disks and a QIC tape
>Now the problem.
>The system boots fine.  And it will mount /dev/rl1a.  But it won't mount
>/dev/rl2a.  I get "/dev/rl2a on /vol2: No such device or address".
>I get the same error when I try to do a disklabel.  What's more, I also
>get this same error when I try to access any of the RA devices.  I am
>using the GENERIC Kernel which I assume has all the devices in it.
>Anybody have any suggestions??
>Of course, if I find that the SCSI Controller isn't going to work
>I have another controller and a FUJI Eagle I could use too. But I
>am certain I will need to get all three RL's working in order to
>have enough of a system to do this.
>Thanks in advance,

Robin Birch

More information about the TUHS mailing list