[pups] Progress on 2.11BSD kernel

Ian King iking at killthewabbit.org
Sat Mar 22 04:08:35 AEST 2003


Now I know I'm missing something.  I tried following your advice, using the
disklabel utility running under the old kernel.  From what you say below, I
assume you are referring to the 'fstype' parameter on the partition, not the
'type' parameter for the drive, correct?  The drive type is MSCP, and the
partition fstype is 2.11BSD.

I tried changing the partition type with disklabel -e -r but, when I exited
vi, I got an error message saying that the type I'd provided was not valid.
Viewing the label (with disklabel -r) showed the fstype set to 'unknown'.

Just for grins, I tried modifying the drive type, too - no success there,
either.  The disklabel utility isn't having any of that; again it claims

Oh well, while I'm waiting for your reply I can rebuild my kernel with a
higher MAXUSERS parameter.  :-)

Thanks -- Ian

----- Original Message -----
From: "Steven M. Schultz" <sms at 2BSD.COM>
To: <pups at minnie.tuhs.org>
Sent: Wednesday, March 19, 2003 9:36 AM
Subject: Re: [pups] Progress on 2.11BSD kernel

> > Now, when I respond to the boot prompt with 'ra(0,0)unix', I'm getting
> > following:
> >
> > <banner for the image, date, time, etc.>
> > panic: iinit
> > no fs on 5/0
> That says the kernel was not able to mount the root filesystem.  The
> earlier messages about the kernel build date, etc appear because
> the kernel prints those directly from internal strings  (and the
> kernel is loaded by /boot who doesn't "mount" the root filesystem).

> The times I have seen the 'iinit' panic it's meant that the disklabel
> was either missing _or_ that the root ('a') partition was not of
> type FS_V71K.   I SUPPOSE it's far fetched, but possible, that the
> old kernel predates the check for the filesystem type, thus it ignores
> the type of partition 'a' and assumes it's a valid filesystem.
> If you have a copy of the standalone 'disklabel' program installed
> in / you can boot that with
> ra(0,0)disklabel
> and examine the label that way.   Or boot the tape and load the
> utility that way.   Using the old kernel and running disklabel
> would work too.   If the 'type' for the 'a' partition is not 'FS_V71K'
> that's the problem.

More information about the TUHS mailing list